D-Link DWA-140 (无线, 802.11n, USB Stick, 300 Mbit/s)

D-Link 友讯, , USB, 无线

D-Link DWA-140 (无线, 802.11n, USB Stick, 300 Mbit/s)
Linux兼容:
5 投票, 平均: 3.4 出最多 55 投票, 平均: 3.4 出最多 55 投票, 平均: 3.4 出最多 55 投票, 平均: 3.4 出最多 55 投票, 平均: 3.4 出最多 5
  ( 3.4 5 等级)



价格走势
D-Link DWA-140 
-
Minimum: ¥ 0.00 
Maximum: ¥ 0.00  
更新: 16/08/2015 04:22

回顾Linux的兼容性

There are at least three different versions of the USB stick with the name D-Link DWA-140, each one using a different version of a Ralink chipset. Not all versions are supported out-of-the-box by the Linux kernel (in case of version B3 the module has to be compiled per hand). Unfortunately the three versions can not be distinguished in the shop, because the packaging is identical. Due to this reason it is not recommended to buy this stick for Linux purposes.

Version 1:
DWA-140 B1

The version B1 has the USB ID 07d1:3c09 and is recognized by the kernel (e.g. openSUSE 11.4) in the following way:

Bus 001 Device 005: ID 07d1:3c09 D-Link System DWA-140 RangeBooster N Adapter(rev.B1) [Ralink RT2870]

The DWA-140 B1 uses the Ralink chipset RT2870 and is supported since Ubuntu 10.04. However, it is necessary to deactivate the kernel module rt2800usb. Therefore, the file

/etc/modprobe.d/blacklist.conf

has to be extended by the line

blacklist    rt2800usb

Alternatively one can do this (as root) by the following command:

echo 'blacklist rt2800usb' | sudo tee -a /etc/modprobe.d/blacklist.conf

The module rt2870sta which is used to control the DWA-140 B1 is located at

/lib/modules/2.6.37.6-0.5-desktop/updates/rt2870/rt2870sta.ko

This module needs several firmware files:

filename:       /lib/modules/2.6.37.6-0.5-desktop/updates/rt2870/rt2870sta.ko
version:        2.1.0.0
license:        GPL
description:    RT2870/RT3070 Wireless Lan Linux Driver
author:         Paul Lin <paul_lin@ralinktech.com>
firmware:       rt3071.bin
firmware:       rt3070.bin
firmware:       rt2870.bin

Version 2:
DWA-140 B2

The version B2 of the DWA-140 has the USB ID 07d1:3c0a and uses the Ralink chipset RT3070.
In oder versions of Ubuntu (until 10.04.2) the module rt2800usb has to be blacklisted as explained above for the version B1.
But the stick is not supported any longer since Ubuntu 10.04.3 by the module rt2870sta.

Instead, since Ubuntu 11.04 the module rt2870sta has to be blacklisted and rt2800usb has to be used together with the latest firmware.

The USB stick DWA-140 B2 is initialized after plugging in in the follwing way:

usb 1-4: new high speed USB device using ehci_hcd and address 4
usb 1-4: New USB device found, idVendor=07d1, idProduct=3c0a
usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-4: Product: 11n Adapter
usb 1-4: Manufacturer: Ralink
usb 1-4: SerialNumber: 1.0

Version 3:
DWA-140 B3

The version B3 of the DWA-140 uses the Ralink chipset RT5370 and has the USB ID 2001:3c15.
The module for this version has to be compiled by hand (german tutorial for comilation of the Module).


确定硬件配置 (4 结果)

这种硬件组件在以下系统配置下使用的Linux用户。这些结果通过收集我们的 扫描工具:
分配
内核版本
等级
扫描日期
PCLinuxOS 4.7.6-pclos1 “用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5 05/10/2016
Debian GNU/Linux 7.11 (wheezy) 3.2.0-4-486 “用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5 10/08/2016
Linux Mint 17.3 Rosa 3.19.0-32-generic “用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5 07/08/2016
Arch Linux 4.2.5-1-ARCH “用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5“用户提供了以下的评价为这个硬件设置:” 4 出最多 5 26/01/2016

类似Linux的硬件

scroll left scroll right

评论

请使用注释部分提出更正的文章,以及相关的摘录 lspci -nnv, lsusb -v, lshw, dmesg ... 此外,使用一节的经验与此硬件组件或搜索该硬件的其他业主配置帮助交流。
 
电子邮件地址不会被公开。
Submitting comment...